import Foundation
let pattern = #"(?:http[s]?:\/\/)?(?:www\.)?([^/\n\r]+\.[^/\n\r]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.instagram.com/Worldfoodprogramme/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)