#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\x00-\x7F]{2,}"
Local $sString = "" & @CRLF & _
"mimusops:mimusops属" & @CRLF & _
"" & @CRLF & _
"words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#$');" & @CRLF & _
"" & @CRLF & _
"β" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.textmagic.com/free-tools/unicode-detector" & @CRLF & _
"https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")