package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\x00-\x7F]{2,}`)
var str = `
mimusops:mimusops属
words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#$');
β
https://www.textmagic.com/free-tools/unicode-detector
https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}