import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\x00-\\x7F]{2,}";
final String string = "\n"
+ "mimusops:mimusops属\n\n"
+ "words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#$');\n\n"
+ "β\n\n\n"
+ "https://www.textmagic.com/free-tools/unicode-detector\n"
+ "https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}