# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\x00-\x7F]{2,}"
test_str = ("\n"
"mimusops:mimusops属\n\n"
"words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#$');\n\n"
"β\n\n\n"
"https://www.textmagic.com/free-tools/unicode-detector\n"
"https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.