// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\x00-\x7F]{2,}").unwrap();
let string = "
mimusops:mimusops属
words_in_text('Düsseldorf, Köln, Москва, 北京市, إسرائيل !@#$');
β
https://www.textmagic.com/free-tools/unicode-detector
https://stackoverflow.com/questions/150033/regular-expression-to-match-non-ascii-characters";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}