#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/^(\+\d{1,3}[- ]?)?\d{10}$/"
Local $sString = "+1 8087339090" & @CRLF & _
"+91 8087339090" & @CRLF & _
"+912 8087339090" & @CRLF & _
"8087339090" & @CRLF & _
"08087339090" & @CRLF & _
"+1-8087339090" & @CRLF & _
"+91-8087339090" & @CRLF & _
"+912-8087339090" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")