package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/^(\+\d{1,3}[- ]?)?\d{10}$/`)
var str = `+1 8087339090
+91 8087339090
+912 8087339090
8087339090
08087339090
+1-8087339090
+91-8087339090
+912-8087339090
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}