$re = '/\b(\d{5}-\d{1,4}|\d{5})\b/m';
$str = 'Zip:
----
98839-0111
34332';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);