#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=\W)|(?<=\W)"
Local $sString = "Hello, "Joe!""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)