import Foundation
let pattern = #"(?=\W)|(?<=\W)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello, "Joe!""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)