#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^\s*"\s*|\s*"\s*$|\s*"?\s*,\s*"?\s*)"
Local $sString = ",Domestic Transactions," & @CRLF & _
"Date ,Transaction Description ,Amount" & @CRLF & _
",Rahul," & @CRLF & _
",," & @CRLF & _
"12-01-2018,STIC TRAVELS PVT LTD DELHI ,32256 cr" & @CRLF & _
"13-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,211687" & @CRLF & _
"14-01-2018,FLEMINGO DUTY FREE Mumbai ,18796.99" & @CRLF & _
"14-01-2018,AIRTEL PAYMENT MUMBAI ,1297" & @CRLF & _
"14-01-2018,AIRTEL PAYMENT CHENNAI ,902 cr" & @CRLF & _
"22-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,5000" & @CRLF & _
",," & @CRLF & _
",Ritu," & @CRLF & _
"17-01-2018,PAYTM NOIDA ,165" & @CRLF & _
"17-01-2018,BIKANERVALA GURGAON ,325" & @CRLF & _
"19-01-2018,VFS GLOBAL SERVICES PVT MUMBAI ,1200" & @CRLF & _
"21-01-2018,Amazon Seller Services BANGALORE ,2155 cr" & @CRLF & _
",," & @CRLF & _
",International Transactions," & @CRLF & _
"Date ,Transaction Description ,Amount" & @CRLF & _
",Rahul," & @CRLF & _
"13-01-2018,SRILANKANUPGRADE KATUNAYAKE EUR,6" & @CRLF & _
"14-01-2018,HEALTHGUARD LIMITED KATUNAYAKE USD,5 cr" & @CRLF & _
"14-01-2018,FOOT RUB BERLIN EUR,20" & @CRLF & _
"20-01-2018,California Games CALIFORNIA USD,100" & @CRLF & _
"30-01-2018,NewYorkShop NEWYORK USD,200 cr" & @CRLF & _
"08-02-2018,EURO WINGS DUSSELDOR EUR,5" & @CRLF & _
",," & @CRLF & _
",," & @CRLF & _
",,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")