import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\s*\"\\s*|\\s*\"\\s*$|\\s*\"?\\s*,\\s*\"?\\s*)";
final String string = ",Domestic Transactions,\n"
+ "Date ,Transaction Description ,Amount\n"
+ ",Rahul,\n"
+ ",,\n"
+ "12-01-2018,STIC TRAVELS PVT LTD DELHI ,32256 cr\n"
+ "13-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,211687\n"
+ "14-01-2018,FLEMINGO DUTY FREE Mumbai ,18796.99\n"
+ "14-01-2018,AIRTEL PAYMENT MUMBAI ,1297\n"
+ "14-01-2018,AIRTEL PAYMENT CHENNAI ,902 cr\n"
+ "22-01-2018,FLIPKART INTERNET PRIVATE BANGALORE,5000\n"
+ ",,\n"
+ ",Ritu,\n"
+ "17-01-2018,PAYTM NOIDA ,165\n"
+ "17-01-2018,BIKANERVALA GURGAON ,325\n"
+ "19-01-2018,VFS GLOBAL SERVICES PVT MUMBAI ,1200\n"
+ "21-01-2018,Amazon Seller Services BANGALORE ,2155 cr\n"
+ ",,\n"
+ ",International Transactions,\n"
+ "Date ,Transaction Description ,Amount\n"
+ ",Rahul,\n"
+ "13-01-2018,SRILANKANUPGRADE KATUNAYAKE EUR,6\n"
+ "14-01-2018,HEALTHGUARD LIMITED KATUNAYAKE USD,5 cr\n"
+ "14-01-2018,FOOT RUB BERLIN EUR,20\n"
+ "20-01-2018,California Games CALIFORNIA USD,100\n"
+ "30-01-2018,NewYorkShop NEWYORK USD,200 cr\n"
+ "08-02-2018,EURO WINGS DUSSELDOR EUR,5\n"
+ ",,\n"
+ ",,\n"
+ ",,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}