re = /^(?!.* (REV|LIB) .*).*$/m
str = '0,5 MG COM CT BL AL/AL X 30
0,4 MG COM REV CT BL AL AL X 90
0,7 MG COM LIB PROL CT BL AL AL X 30
0,4 MG COM CT REV BL AL AL X 90'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end