$re = '/^(?!.* (REV|LIB) .*).* COM .*$/m';
$str = '0,5 MG COM CT BL AL/AL X 30
0,4 MG COM REV CT BL AL AL X 90
0,7 MG COM LIB PROL CT BL AL AL X 30
0,4 MG COM CT REV BL AL AL X 90
0,4 MG COMERCIAL CT REVENDEDOR BL AL AL X 90
0,4 MG REV COM CT BL AL AL X 90
0,7 MG LIB PROL COM CT BL AL AL X 30
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);