import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?(?!\\.(?!\\d)|$)\\d*(?:\\.\\d*)?(?:(?<=[\\d.])e[+-]?\\d+)?$";
final String string = "0\n"
+ ".\n"
+ ".0\n"
+ "0.\n"
+ "0.0\n"
+ "1\n"
+ "123456.789\n\n"
+ "e123\n"
+ "1e4\n"
+ "1e4.5\n"
+ "1.4e4\n"
+ "1.4\n"
+ "1.4e\n"
+ "1.4e0\n"
+ "1.e4\n"
+ ".e4\n"
+ "0.e4\n"
+ "-\n"
+ "1e-4\n"
+ "1e+4\n"
+ "1e-\n"
+ "1e+";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}