$re = '/^[+-]?(?!\.(?!\d)|$)\d*(?:\.\d*)?(?:(?<=[\d.])e[+-]?\d+)?$/im';
$str = '0
.
.0
0.
0.0
1
123456.789
e123
1e4
1e4.5
1.4e4
1.4
1.4e
1.4e0
1.e4
.e4
0.e4
-
1e-4
1e+4
1e-
1e+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);