#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(foo)(.{5})"
Local $sString = "sdfsdffoocharssdfsdfsdf"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)