using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(foo)(.{5})";
string substitution = @"";
string input = @"sdfsdffoocharssdfsdfsdf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}