using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input type=""hidden"" value=""(.*?)"" name=""_csrf"">";
string input = @"<input type=""hidden"" value=""a5a40c7c-232e-47e5-9059-964af24933e9"" name=""_csrf"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}