use strict;
my $str = '<input type="hidden" value="a5a40c7c-232e-47e5-9059-964af24933e9" name="_csrf">';
my $regex = qr/<input type="hidden" value="(.*?)" name="_csrf">/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}