re = /<input type="hidden" value="(.*?)" name="_csrf">/
str = '<input type="hidden" value="a5a40c7c-232e-47e5-9059-964af24933e9" name="_csrf">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end