// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input type="hidden" value="(.*?)" name="_csrf">"#).unwrap();
let string = "<input type=\"hidden\" value=\"a5a40c7c-232e-47e5-9059-964af24933e9\" name=\"_csrf\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}