# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\?|"\]$//gm;t' <<< "[\"//xxx.com/se/something?SE_{ifmobile:MB}{ifnotmobile:DT}_A_B_C_D_E_F_G_H\"]
[\"//www.xxx.com/se/car?p_color_car=White?SE_{ifmobile:MB}{ifnotmobile:DT}_A_B_C_D_E_F_G_H\"]"