import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)";
final String string = "https://example.com?email=abc&xyz@.com&isAvailableReferral=true\n"
+ "https://example.com?email=abc@xyz.com&isAvailableReferral=true\n"
+ "https://example.com?email=abc&xyz@.com\n"
+ "https://example.com?email=abc@xyz.com\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}