import Foundation
let pattern = #"\?(firstName|lastName|email|phone1|address)=([^&]*(?:&[^&=]+(?=&|$))*)(?:&|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://example.com?email=abc&xyz@.com&isAvailableReferral=true
https://example.com?email=abc@xyz.com&isAvailableReferral=true
https://example.com?email=abc&xyz@.com
https://example.com?email=abc@xyz.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)