# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)/$1/mg;t' <<< " PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] "