using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n*\w*\s*)PlayerPoints[^2]\[(.+?)\](\n*\w*\s*)";
string substitution = @"$1";
string input = @" PlayerPoints1[300] PlayerPoints2[400] PlayerPoints3[500] PlayerPoints6[700] ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}