const regex = /^((?:(?:[A-Z][a-z]+)(?>\s*))+)([\s\S]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:(?:[A-Z][a-z]+)(?>\\s*))+)([\\s\\S]+)', '')
const str = `09/28/2016
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}