$re = '/\d{3}\.\d{3}\.\d{1}\.\d{1}/';
$str = '192.168.1.1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);