re = /^FILTER$(.*?)^ORDER$((?:(?!^FILTER$).)*)/m
str = 'FILTER
test1 FILTER ORDER
ORDER
test2
FILTER
ORDER FILTER test3
ORDER
FILTER
ORDER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end