#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!yellow.*).*blue(?=.*brown)"
Local $sString = "yellow blue brown // shouldn't match" & @CRLF & _
"f blue brown // should match" & @CRLF & _
"sdff blue brown // should match" & @CRLF & _
"asdf f blue c // shouldn't match" & @CRLF & _
"yellow blue fblue b f brown // shouldn't match" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")