re = /^(?=.{8,16}$)(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9]).*$/m
str = 'hsdhsh0A
hsdhshuA
hsdhshuAhsdhsh8A
hsdhshuAhsdhsh8Aoi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end