const regex = /^(apple|mango|banana) is (\d+)kg$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(apple|mango|banana) is (\\d+)kg$', '')
const str = `apple is 21kg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}