const regex = new RegExp('(?P<name>[\\s\\w]+){1}\\s(?P<phone>\\d+)?\\s(?P<email>[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\\.[a-zA-Z0-9-.]+)?\\s+(?:C:\\s*(?:\\s*(?P<company>(?:[\\s\\w]+))))?\\s+(?:N:\\s*(?P<notes>[\\s\\w]+))', 'gm')
const str = `Artem Gladkov 89299992886 gladkov@kaspersky.com C: Kaspersky Awes N: Notes from me f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}