import Foundation
let pattern = ##"^#\s*User@Host:\s*root\[root\]\s*@\s*localhost\s*\[\]$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Time: 230706 17:12:48
# User@Host: sample[sample] @ localhost []
# Thread_id: 626784 Schema: sample QC_hit: No
# Query_time: 2.976557 Lock_time: 0.000178 Rows_sent: 0 Rows_examined: 3344231
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688677968;
SELECT * from a;
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs;
# Time: 230706 17:13:37
# User@Host: sample[sample] @ localhost []
# Thread_id: 627027 Schema: oiemorug_wp598 QC_hit: No
# Query_time: 3.901325 Lock_time: 0.000145 Rows_sent: 0 Rows_examined: 3851050
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678017;
SELECT * from b
# Time: 230706 17:15:51
# User@Host: root[root] @ localhost []
# Thread_id: 627770 Schema: sample QC_hit: No
# Query_time: 2.581676 Lock_time: 0.000270 Rows_sent: 0 Rows_examined: 2432228
# Rows_affected: 0 Bytes_sent: 195
SET timestamp=1688678151;
select * from cs
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)