re = /<iframe(?!<\/iframe>)[\s\S]*?data-context[\s\S]*?<\/iframe>/i
str = '<iframe src="http://youtube.com"></iframe>
<iframe data-context="whatever" src="http://youtube.com"></iframe>
<iframe src="http://youtube.com"></iframe> <iframe src="http://youtube.com"></iframe>
<p>Potatoes are good</p>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://youtube.com" data-context="whatever"></iframe>
<iframe src="http://youtube.com"></iframe>
<iframe src="http://instagram.com"></iframe> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end