#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([#&\s])\1+"
Local $sString = "Actividades Financieras && Bancarias #### 23"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)