re = /([#&\s])\1+/
str = 'Actividades Financieras && Bancarias #### 23'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result