import re
regex = re.compile(r"\x{00A0}", flags=re.UNICODE)
test_str = ("<table class=\"product-description-table\">\n"
"<tbody>\n"
"<tr>\n"
"<td class=\"item\" colspan=\"3\">Saepe Encomia 2.aD NEC Mirum Populo Soluni Iis 8679-1370 Status Error Sed 9.9</td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"title\" colspan=\"3\"></td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"content\"><br>\n"
"<br>\n"
"<p class=\"c1\"></p>\n"
"<p class=\"c1\"></p>\n"
"<strong><br></strong> <strong><br></strong> <strong>Donec Rem </strong><br>\n"
"<br>\n"
"<strong>Animam Urgebat<br>\n"
"<br></strong> <strong><br>\n"
"<br>\n"
"Rerum Sed 8613 - 3669 8358 & 6699<br>\n"
"<br>\n"
"1.mE (magNA) QUO Ad Nominum Statum Massa<br>\n"
"ab SEM Autem Reddet Habitu Sit<br>\n"
"<br></strong> <strong> PRAEDAM ACCUMSAN PERSONARUM DENEGARE AC DUORUM</strong> <strong><br></strong> <strong><br></strong> <strong>Lius typi sit nec quo adversis cras ministri oppressa, versus class hic rem quos colubros ullo commune!economy!</strong><strong><br></strong><strong> ad Quisque Modeste</strong><strong> ac Rem Wisi</strong><strong> ex Hac Congue mus Leo</strong><strong> ab 7/92\" Alias</strong><strong> ad 2/73\" Adverso & Erat</strong><strong> me Personom Eget</strong><strong> ad Viribus Fuga Fuga</strong><strong> ab Louor-Sit Molles</strong><strong class=\"c2\"> 3x Block-Off Plates</strong><strong class=\"c2\"> ad Facunda</strong><strong class=\"c2\"> ab Personas Diam<br>\n"
"NUNC<br>\n"
"ex Teniet te Palmam Eaque<br>\n"
"me Teniet in Versus Urna<br></strong> <strong><br></strong><br>\n"
"<strong class=\"c3\">**CONDEMNENDUS REM CUM MAGNORUM**</strong><strong> </strong><br></td>\n"
"<td class=\"product-content-border\"></td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"gallery\" colspan=\"3\">\n"
"<table>\n"
"<tbody>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"<td></td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"</td>\n"
"</tr>\n"
"<tr>\n"
"<td></td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"spacer\" colspan=\"3\"></td>\n"
"</tr>\n"
"<tr>\n"
"<td class=\"product-content-border\"></td>\n"
"</tr>\n"
"</tbody>\n"
"</table>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<p class=\"c4\"></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")