# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"[a-zA-Z 0-9]+)(?:-\d)+(?=\")"
test_str = ("\"Article number\" \"Name\" \"Third Column\"\n"
"\"Shorts Artic\" \"Swa...\" \"2018-07-28\"\n"
"\"Shorts Artic-1\" \"Swa...\" \"stl 31-35-1-1-1-1-2-2-2-1-1\"\n"
"\"Shorts Artic-2-1\" \"Swa...\" \"https://test-domain.com/...\"\n"
"\"Shorts Artic-2-2-1\" \"Sw...\" \"\"\n"
"\"Shorts Artic-2-2-2-2-1\" \"Ba...\" \"-asd\"\n"
"\"Shorts Artic-2-2-2-2-2-1\" \"Nus...\"\n"
"\"Shorts Artic-2-2-2-2-2-1-1\" \"Lek..\"\n"
"\"0858-1\" \"Jacket Blue..\"\n"
"\"0858-2-1\" \"Jacket Re..\"\n"
"\"0858-2-2-1\" \"Int...\"\n"
"\"0858-2-2-2-1\" \"In...\"\n"
"\"0858-2-2-2-2-1\" \"Int...\"\n"
"\"0858-2-2-2-2-2-1\" \"Int...\"\n"
"\"0858-2-2-2-2-2-2-1\" \"Int...\"\n"
"\"0858-2-2-2-2-2-2-2-1\" \"In...\"\n"
"\"0858-2-2-2-2-2-2-2-2\" \"In...\"\n"
"\"0858-2-2-2-2-2-2-2-1\" \"In...\" \"6 107-124 cm\"")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.