# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})/$1.$2.$3.$4/g;t' <<< "kube_node_info{container_runtime_version=\"docker://18.6.1\",endpoint=\"http\",instance=\"10.11.111.111:8080\",job=\"kube-state-metrics\",kernel_version=\"xxxxx\",kubelet_version=\"xxxx\",kubeproxy_version=\"xxxx\",namespace=\"infra\",node=\"ip-10-11-111-111.us-sdlls-as.compute.internal\",os_image=\"Amazon Linux 2\",pod=\"prometheus-operator-kube-state-metrics-sdfgsjdkgl-saldjl\",service=\"prometheus-operator-kube-state-metrics\"}"