import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2,3})-(\\d{2,3})-(\\d{2,3})-(\\d{2,3})";
final String string = "kube_node_info{container_runtime_version=\"docker://18.6.1\",endpoint=\"http\",instance=\"10.11.111.111:8080\",job=\"kube-state-metrics\",kernel_version=\"xxxxx\",kubelet_version=\"xxxx\",kubeproxy_version=\"xxxx\",namespace=\"infra\",node=\"ip-10-11-111-111.us-sdlls-as.compute.internal\",os_image=\"Amazon Linux 2\",pod=\"prometheus-operator-kube-state-metrics-sdfgsjdkgl-saldjl\",service=\"prometheus-operator-kube-state-metrics\"}";
final String subst = "$1.$2.$3.$4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}