re = /(\d{2,3})-(\d{2,3})-(\d{2,3})-(\d{2,3})/
str = 'kube_node_info{container_runtime_version="docker://18.6.1",endpoint="http",instance="10.11.111.111:8080",job="kube-state-metrics",kernel_version="xxxxx",kubelet_version="xxxx",kubeproxy_version="xxxx",namespace="infra",node="ip-10-11-111-111.us-sdlls-as.compute.internal",os_image="Amazon Linux 2",pod="prometheus-operator-kube-state-metrics-sdfgsjdkgl-saldjl",service="prometheus-operator-kube-state-metrics"}'
subst = '$1.$2.$3.$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result