using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\u23F1.\W|[\d]+)(\'|\s|’|‘)*(/|\||\[|-)+)|((/|\||\[)+(\s)*(?:\u23F1)*(\s)*[\d]{1,2}[^x](\s)*(min|mi|m)*)";
string input = @"((?:\u23F1.\W|[\d]+)(\'|\s|’|‘)*(/|\||\[|-)+)|((/|\||\[)+(\s)*(?:\u23F1)*(\s)*[\d]{1,2}[^x](\s)*(min|mi|m)*)
2ºT | ⏱ 48 min: cruzamento de Raphael Veiga e Felipe Melo cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 47 min: amarelo para Raphael Veiga. \n\n#PALxCHA | 3x1\n#AvantiPalestra
2ºT | ⏱ 45 min: mais 4 minutos de acréscimos. \n\n#PALxCHA | 3x1\n#AvantiPalestra
2ºT | ⏱ 42 min: cruzamento preciso de Luan do meio-campo e Rony cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 28 min: substituições 🔄\n\n🔼 Entram: L. Esteves e F. Melo \n🔽 Saem: Wesley e G. Scarpa
2ºT | ⏱ 26 min: amarelo para Wesley. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
Com a saída de Luiz Adriano, Willian passa a ser o capitão do time em campo ©️\n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão https://t.co/PbpAHZH68u
2ºT | ⏱ 25 min: substituição 🔄\n\n🔼 Entra: Willian \n🔽 Sai: Luiz Adriano \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 21 min: após bate e rebate, Zé Rafael fica com a bola e manda por cima do gol. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão
2ºT | ⏱ 9 min: Palmeiras 3x1 Chapecoense. \n\n#AvantiPalestra #PALxCHA\n#JuntosNoBrasileirão
2ºT | ⏱ 3 min: jogada ensaiada em cobrança de escanteio: Gustavo Scarpa cruza na entrada da área para 45' | 2T | +6. Jogo vai aos 51. \n\nABC Futebol Clube 3x0 Chapecoense\n \n#VamosChape
43' | 2T | Entra Felipe Santana no lugar de Matheus Ribeiro. \n\nABC Futebol Clube 3x0 Chapecoense\n
45' | 2T | +4. Jogo vai aos 49. \n\nPalmeiras 3x1 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape
35' | 2T | Muda a Chape:\n\nEntram ➡️ Bruno Silva e Geuvânio\nSaem ⬅️Fabinho e Anselmo Ramon
32' | 2T | Adversário cobra falta, mas a bola desvia na barreira e sai em escanteio. \n\nPalmeiras 3x1
24' | 2T | QUAAAAAAAASEEEEEEEEEE! \n\nRavanelli manda no segundo pau e Anselmo Ramon finaliza de
13' | 2T | Ravanelli tocou para Matheus Ribeiro, que invadiu a área a finalizou na rede, mas pelo lado
7' | 2T | Falta para a Chapecoense na meia-lua da grande área. \n\nPalmeiras 3x0 Chapecoense\n
7' | 1T | Gol do Palmeiras. \n\nPalmeiras 1x0 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape
2' | 1T | UHHHHHHHHHHHHHHHHHHH!\n\nFabinho fica cara a cara com Jailson e finaliza, obrigando grande
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}