import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:LA(?:2[123]|1[12]|[789])|CA1[012])$";
final String string = "LA7\n"
+ "LA8\n"
+ "LA9\n"
+ "LA11\n"
+ "LA12\n"
+ "LA21\n"
+ "LA22\n"
+ "LA23\n"
+ "CA10\n"
+ "CA11\n"
+ "CA12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}