# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9][0-9| ]*/?[0-9| -]*[0-9])"
test_str = "Tel: 02342/379 287 Mob: 06790/3234-232 Gesch: 22375 Tel2: 033 82/27-8-84 / 27437"
subst = "<a href=\"tel:\\1\">\\1</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.