package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)102\d2015`)
var str = `title_10212015_0001.jpg
title_10222015_0002.jpg
title_10232015_0003.jpg
title_10232015_0005.jpg`
var substitution = "10212015"
fmt.Println(re.ReplaceAllString(str, substitution))
}