const regex = /("([^"]*)")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("([^"]*)")', 'gm')
const str = `Mein Name ist "Joseph"`;
const subst = `„$2“`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);