$re = '/("([^"]*)")/m';
$str = 'Mein Name ist "Joseph"';
$subst = "„$2“";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;